• Log In | Sign Up

  • News
  • Reviews
  • Games Database
  • Game Discovery
  • Search
  • New Releases
  • Forums
continue reading below

Adventure Gamers - Forums

Welcome to Adventure Gamers. Please Sign In or Join Now to post.

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Post Marker Legend:

  • New Topic New posts
  • Old Topic No new posts

Currently online

Support us, by purchasing through these affiliate links

   

Gabriel Knight 3 Windows 10 Guide (GOG)

Total Posts: 46

Joined 2020-01-20

PM

Hi!

I’m not technically new, but I forgot my password and my nick. Anyway, I struggled with getting Gabriel Knight 3 to run smoothly on Windows 10 for weeks so I figured I should post a guide here since we’re all Adventure Gamers here Smile I hope this helps someone who is struggling with getting the game to run on Win10, even if it’s months from when I posted this. I achieved all this by trial and error, so I don’t know if every step is required.

1. Install Gabriel Knight 3 to C: directory. Don’t use any pre-set folder suggestions. Just put it in C:

2. Download the latest release of dgVoodoo2

2. Unrar/Unzip the dgvoodoo folder, and COPY every single .dll file from MS->x86 and 3Dfx -x86 folders.

3. PASTE all of them to the Gabriel Knight 3 Folder. It’s important you paste the files, and not the folders. And make sure they’re all x86 and not the other (for 32bit games).

4. Now open dgVoodooCpl and Add a new game. Choose the C:\Gabriel Knight 3 FOLDER and click OK.

5. Inside dgVoodooCpl, Go to DirectX TAB.

5. Enable “Force VSync, Fast Video Memory Access”. You can also set anti-aliasing to 8.

6. Under “GENERAL”-tab choose Windowed or Full Screen (try out which one works the best for you)

7. Click on Apply and leave the window open.

You can toggle things like anti-aliasing under DirectX.
Also try to play around with the Graphics Settings within the game itself. You can change resolution to your current monitor’s setup but for me it caused issues so I prefer the 4:3 ratio.

If you’re still having issues, go to DirectX tab again and try different graphics cards settings with different amount of Vram. Usually less is better for the game. The best solution is to use dgVoodoo Virtual 3D Card with maximum 128MB of Vram.

I have NOT been able to run the game full screen without issues. If I do, it looks just fine, but wherever I hover my mouse over, the area becomes “wonky” (the graphics) where I leave my mouse. If someone knows a fix, do let me know!

Side note: On my PC, I use Full Screen from General TAB and Scaling Mode is Centered. From DirectX TAB I’ve tweaked this under resolution to 4x, so it’s not too small. To me it is 4:3 screen in the center. The graphics aren’t the best possible but they’re sharp, there is literally NO lag and I’ve yet to receive another DirectX error nor Fatal Error.

     

Total Posts: 8

Joined 2020-12-03

PM

I just installed it, works flawlessly on Win 10. I’m using the steam version but GOG should be the same. Here are the steps:

1) install game
2) get GOG patch (also works for steam version) from http://files.gog.com/support/GK3.zip
4) Extract gk3.exe from zip
5) Make backup of original GK3.exe in your install directory
6) Replace GK3.exe with new gk3.exe from GOG patch
7) Insert any Disc in your Disc drive OR (if your PC doesn’t have any disk drive) download and mount (by double clicking the downloaded file) an iso image like i.e. http://tinycorelinux.net/11.x/x86/release/Core-current.iso
-> if you don’t do this you’ll get an error stating insert disc.
8 ) start the game
9) if you have problems with graphics like flickering, in the game go to
Options—> advanced options—> graphic options—> change 3D Driver to Software Renderer

Done.

     

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Welcome to the Adventure Gamers forums!

Back to the top