Adventure Forums - View Single Post - Amber's Blood Installation Issues - Administrator please VIEW.
View Single Post
Old 03-15-2012, 01:26 PM   #1
Mina32
Junior Member
 
Join Date: Mar 2012
Posts: 2
Default Amber's Blood Installation Issues - Administrator please VIEW.

Hello I have bought and trying to download Amber's Blood and it will not download. I have used the Metaboli downloader and also tried to download manually. To me, it seems there is a problem with the game download itself. Can anyone help me or tell me who or what to contact for help? I have downloaded tons of games from the Adventure Shop and never had any problems before. Now, when I try to download I get a message about how my download has timed out after 3 attempts and to please check my internet connection. My internet is fine. I even tried downloading it on my husband's laptop and got the same message.


EDIT: I have also tried downloading on my mother's computer and am getting the same message that download TIMES OUT AFTER 3 ATTEMPTS. I have also tried to download my other games through the downloader and they are downloading fine so there is some problem with Amber's Blood game download in itself. Can someone help?

Last edited by Mina32; 03-15-2012 at 04:27 PM.
Mina32 is offline