Adventure Forums - View Single Post - Game you're playing. How far you are.
View Single Post
Old 06-12-2009, 08:57 PM   #1450
AprilLives
Senior Member
 
AprilLives's Avatar
 
Join Date: Jun 2006
Posts: 366
Default Sacred Rings

Sacred Rings, near the end. I was enjoying the game and looking forward to some beautiful final scenes when I realized I don’t have the tetrahedron to proceed. Where did it go? It’s not in my inventory. I had it early on and probably tried using it on some puzzles along the way.

Someone who reviewed the game could have an explanation as to why my tetrahedron went missing.

I quote: “There are also two major bugs, and, as of this writing there are no known patches. However, there is a gameplay around them that I discovered. On the "letters" puzzle in the graveyard, do NOT touch any of your inventory against this puzzle, or they will disappear and you will not be able to retrieve them. Secondly, when clicking on Reina to begin the lightning spell, be sure to click on her with something from your inventory. Otherwise, when you arrive in the land of the Shadow Legion, you will not be able to access your inventory.”

Either one of these possibilities could have caused my tetrahedron to disappear. And since the game doesn’t allow for a lot of saves, I have no saves with the tetrahedron still in it.

So here I am near the end of the game. And the only way of finishing is to start all over again. Sigh!
__________________
Life Is A Riddle Waiting To Be Solved


Favorite Adventure Games:
Riven, The Longest Journey 1, Syberia 1 & 2, Grim Fandango, Still Life 1, Broken Sword Series, Lost Crown

Heavy Rain (Action/Adventure)
AprilLives is offline