• Log In | Sign Up

  • News
  • Reviews
  • Games Database
  • Game Discovery
  • Search
  • New Releases
  • Forums

Adventure Gamers - Forums

Welcome to Adventure Gamers. Please Sign In or Join Now to post.

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread


   

dosbox conf fix for audio glitches?

Avatar

Total Posts: 114

Joined 2013-04-13

PM

I have an underpowered laptop, but I seem to remember being able to run dosbox before so that games would play fluidly without sound-glitching.  For some reason I can no longer accomplish this. I’ve just been trying to play through Freddy Pharkas and it is glitching like crazy. 

I have been messing with trying different settings on the core/cputype/cycles part to no avail.  Also modifying the blocksize in the sound settings only seems to help a little.  anyone have suggestions for the best settings to try?  I know I had it working better before…

my settings are currently :

core=auto
cputype=auto
cycles=auto
cycleup=512
cycledown=512


nosound=false
rate=44100
blocksize=4096
prebuffer=60

my specs are amd c-60 1ghz (overdrive to 1.6, but I’m not sure if it’s even working in xp which I have currently installed) with radeon mobile 6290. (shared 256mb ram I believe. really slow yes)  3gb ram.

thanks for any ideas

     
Avatar

Total Posts: 2573

Joined 2005-08-12

PM

In my experience, setting cycles to auto is almost never a good idea. Set it to some reasonable fixed value (e.g. cycles=fixed 8000), and experiment with the number until you find something that works for you.

     

Currently playing:
Recently finished: Sam & Max: The Devil’s Playhouse (R) (4/5) | Detective Di (3.5/5) | Ace Attorney: Trials and Tribulations (R) (4.5/5) | Heaven’s Vault (3/5) | Ace Attorney: Justice For All (R) (3.5/5) | Phoenix Wright: Ace Attorney (R) (4.5/5) | Sam & Max Beyond Time and Space (R) (4.5/5) | The Infectious Madness of Doctor Dekker (abandoned) (2/5) | Assassin’s Creed Odyssey (3.5/5) | The Sexy Brutale (R) (4/5)

Avatar

Total Posts: 114

Joined 2013-04-13

PM

yeah thanks.  it seems to help a little.  8000 seemed more glitchy than 4000.  i don’t know what else to try… i did notice that it really only glitches when there is video changes going on.  for example, during fade ins/fade outs or screen scrolls it will glitch like crazy.  i’m talking about the midi/adlib music.  i’m not even sure if the actual audio fx glitch at all.  could there be some kind of video/audio conflict going on?  On a single screen it isn’t glitching at all… but when it scrolls everything skip skip skips until it loads up the next screen.  same with fade outs etc. i’m wondering if theres anything i need to fix on my driver side of things.  i did read before about conflicts of audio and video set to the same address or something.  heh not sure where to look into this though.. thanks for any other ideas

     
Avatar

Total Posts: 473

Joined 2008-01-09

PM

Try the official FPFP site below.  A couple of tips there.

http://freddypharkas.com/gameinfo.php

     
Avatar

Total Posts: 88

Joined 2012-07-10

PM

Why don’t you play it via ScummVM? Much more simple.

     

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Welcome to the Adventure Gamers forums!