• Log In | Sign Up

  • News
  • Reviews
  • Games Database
  • Game Discovery
  • Search
  • New Releases
  • Forums
0 new post/s since your last visit
0 new comment/s since your last visit
Last visited on 12/09/19 at 03:35 pm

Adventure Gamers - Forums

Welcome to Adventure Gamers. Please Sign In or Join Now to post.

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread


   

Black Screen on Starting Evidence: The Last Ritual

Total Posts: 1

Joined 2012-11-09

PM

I am terribly sorry if I’m posting in the wrong place, or if there’s another topic to this effect that I’ve been unable to find with searching!

Anyway, I run Windows 7 and DirectX 11.  My video card is a Radeon HD 3800 with 2 gigs of VRAM, and I’ve 4 gigs of system RAM.  I *think* that’s everything I the “Read This!” post mentioned that I needed to give!  Sorry if it isn’t. 

I have Evidence installed just fine, and I’m able to get through the in-game ‘registration’ with no problems and have received an email with my password for the game.  However, when I attempt to log in, it appears to process my username and password and then goes to a black screen.  I’ve let it sit this way for five minutes straight to no effect.  One suggestion I’d seen given for a similar problem with this game on the old Adventure Gamers forum said that updating to the latest version of Quicktime would fix this issue, but when I tried that, I got a popup on attempting to launch the game telling me to please install Quicktime 6 from the root directory of the installation CD.  I’ve tried running the game in 98/Me compatibility mode, which has had no effect on the issue.  I always run older games as administrator as well.

Any suggestions, or am I out of luck?  Thank you in advance for your time!

     

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Welcome to the Adventure Gamers forums!