• Log In | Sign Up

  • News
  • Reviews
  • Games Database
  • Game Discovery
  • Search
  • New Releases
  • Forums
continue reading below

Adventure Gamers - Forums

Welcome to Adventure Gamers. Please Sign In or Join Now to post.

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Post Marker Legend:

  • New Topic New posts
  • Old Topic No new posts

Currently online

DCastJerry

Support us, by purchasing through these affiliate links

   

Necronomicon The Dawn Of Darkness (different versions? and saving game)

Total Posts: 2

Joined 2007-06-30

PM

I am playing necronomicon: the dawn of darkness.

the game seems to have multiple versions out there. (is that right?)

I got to a point where i was in a lab and there was a lot of options, and a walkthrough said go right and use coal bin. but there was no coal bin.

edit: it is gone in this version, or does not matter. so annoying.


the videos I saw on youbtube shows and interactable (word?) coal bin but the one in my game did not have icon/ability to interacts…

also, in the youtube video, some of the alchemy stuff was different. in my game this green vial is already made, and in the youtube game it was not. there are supposed to be jars I use…and they literally are not there.

anway, I tried to make a “solution” and I screwed it up. but the game has no save option that I could find. I was like F#DK it, so I went back and started game over because I had missed one book. I thought maybe that screwed things up. I am back in lab, but afraid to touch anything. there is no manual…anytyhing. on how to save game. I am kind of at a loss with the issue of the fact that the walkthrough/videos are different than my verison and that I can’t seem to save.

I went to exact same spot in game. i think i am suppose to mix something into a green solution, but it may be different in this version.


edit: it seems the game has been dumbed down. you don’t mix solutions of metals, you just load up a syringe. THEN…frustatingly, the in game lore says to mix 3 ingredients (the usual select item and click. I could only get first item to go on floor. it kept saying the other two items were not needed/or something to that effect. i knew they were right both the in game instructions and UHS guide said so. finally I was like “screw it” and I set the single ingredient on floor on fire….and it worked. I don’t know if there were multiple ingredients in my inventory (they were part of a kit) and somehow they got on floor…but there was no message that they did like with the first ingredient. I spent 45 minutes EFFING around with this puzzle when in the end all I had to do was simply set the ingredients on fire…they were either there and the game was not telling me right, or the new version did not care if you had all of them set up right. so wierd.

end rant.

     

You are here: HomeForum Home → Gaming → Hint Requests & Technical Problems → Thread

Welcome to the Adventure Gamers forums!

Back to the top