(King's Quest 7) question! please try to answer - Adventure Forums
You are viewing an archived version of the site which is no longer maintained.
Go to the current live site or the Adventure Gamers forums
Adventure Gamers

Home Adventure Forums Gaming Hint Requests and Technical Problems (King's Quest 7) question! please try to answer


 
 
LinkBack Thread Tools
Old 09-08-2004, 12:35 PM   #1
Junior Member
 
Join Date: Sep 2004
Posts: 1
Default (King's Quest 7) question! please try to answer

ok, so i was recently going through my old games and came across king's quest VII. obviously i had to play it. the problem is when i go to play it, i get a little window saying 'An priviledged instruction was executed at address (insert numbers here)'. is there anything i can do about this? thanks for your help,
~PKS
pinkkillersheep is offline  
Old 09-08-2004, 12:47 PM   #2
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

Welcome to the forum! Since this is a tech problem, I moved it into the hints / tech forum for you.

First of all - what operating system are you using? If it's XP, have you tried putting the game in compatibility mode?

Is this the DOS version of KQ7, or the Windows version?

Please also tell us what you've done up until this point. Have you installed the game but are unable to launch it? Or do you get this message when you try to install? What did you do just before the message appeared?

emily
fov is offline  
Old 09-09-2004, 12:33 AM   #3
Senior Member
 
Captain Blondebeard's Avatar
 
Join Date: Aug 2004
Location: Tornado Alley
Posts: 1,541
Default

Quote:
Originally Posted by pinkkillersheep
ok, so i was recently going through my old games and came across king's quest VII. obviously i had to play it. the problem is when i go to play it, i get a little window saying 'An priviledged instruction was executed at address (insert numbers here)'. is there anything i can do about this? thanks for your help,
~PKS
I have windows XP and when i recently installed Torrins Passage I got a similiar message. Both of these games were Sierra products and came out around the same time. I had to run the game in Windows 95 compatibilty. Right click on the launch icon and click on properties, compatibility and choose windows 95. You may have to lower the graphic setting in the same box.
__________________
Glad to have my old username back. GhostPirateLechuck no longer.
Captain Blondebeard is offline  
Old 09-18-2004, 01:38 AM   #4
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default Problems

I folowed your tips. Now it says that "DLL is not initialised" and then "the instruction at 00000000 referenced memory at 00000000 cannot be read from". It says this when I try to start the game up. I also have XP. Any tips, idea's? You'd do me a huge favor!!!!
morriam is offline  
Old 09-18-2004, 07:43 AM   #5
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

Did you also set the game to compatibility mode before starting it?

-emily
fov is offline  
Old 09-19-2004, 01:46 AM   #6
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default compatibility?

I don't know. What is it and how do I do it?
morriam is offline  
Old 09-19-2004, 02:23 AM   #7
The Thread™ will die.
 
RLacey's Avatar
 
Join Date: Jan 2004
Location: United Kingdom
Posts: 22,542
Send a message via ICQ to RLacey Send a message via AIM to RLacey Send a message via MSN to RLacey Send a message via Yahoo to RLacey
Default

Quote:
Originally Posted by morriam
I don't know. What is it and how do I do it?
It's a system that can help you to run a lot of old Windows games. Here's how:

Right-click on the shortcut to the game (on on the game .exe file itself).
Click the tab marked 'Compatability'.
You should now be presented with a list of options. Click the box next to 'Run this program in compatability mode for:', and then choose Windows 95. Click OK, and try running the game. If this setting doesn't work, try tinkering with some of the other settings on the 'Compatability' tab.

If none of this works, check to see if your copy of King's Quest VII has a DOS mode (mine does). It requires you to run a separate install program. Once you have this version installed, you could try running it using DosBox.

I hope this helps.
__________________
RLacey | Killer of the Thread™

I do not change to be perfect. Perfect changes to be me.


RLacey is offline  
Old 09-23-2004, 06:56 AM   #8
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default still doesn't work

I tried your tips. unfortinatly it still doesn't work. I can't install a dos version. Thanks for your reply though. Does anyone else have an idea?
morriam is offline  
Old 09-23-2004, 12:01 PM   #9
Junior Member
 
Join Date: Sep 2004
Posts: 4
Default Solved!

I actually was able to solve the problem through the Sierra website. Here's the answer...

Solution:
If you get a message like "...referenced memory at xxxx....the memory could not be read from," it typically indicates a memory conflict between Microsoft's Win32S (used by the game to speed up graphics), and something else in the system. You can generally correct it by disabling the game's use of Microsoft's Win32S.


To do this:
1) Copy the File SIERRAW.EXE from the King's Quest 7 CD to the game's directory on your hard drive (usually C:\SIERRA\KQ7).


2) Highlight the icon for King's Quest 7. Press ALT+Enter on the keyboard to bring up the FILE PROPERTIES box. Go into the Command Line box. Move over in the box until you find SIERRAWS.EXE. Delete the S following the W, so it becomes SIERRAW.EXE. Do not change or adjust anything else. Click on the OK button. You should see your King's Quest icon change if you did everything correctly.


Note that this may slow gameplay a little, but you should not experience the problem any longer.


Hope this helps someone else as well....

Last edited by fov; 02-07-2005 at 06:53 PM. Reason: disabled smilies so the c: prompt didn't look like a crying guy
morriam is offline  
Old 09-24-2004, 05:46 PM   #10
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

Thanks for posting the response! That is such a weird solution. I wonder what changing the name of the .exe has to do with anything.

I'll stick this info in my box of Sierra tricks for the next time something like this comes up...

emily
fov is offline  
Old 10-09-2005, 06:43 AM   #11
Junior Member
 
Join Date: Oct 2005
Posts: 1
Default XP doesn't really like old action games, does it?

Hi, I'm new to this board and I'm not sure if there's an answer for this kind of problem but I'll ask anyway

When I try to play the game I get an error "Windows title not found", I've tried every compatibility modes but they don't work either. Does anyone have any idea of what to do?
Antti-san is offline  
Old 10-13-2005, 08:50 AM   #12
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

Welcome to the forum.

Are you on XP? Is it a Windows version of the game (installed using setup.exe), or a DOS version (installed using install.exe)?

I feel like I've heard of this problem before, but can't remember where or when. Sorry, not much help.
fov is offline  
Old 10-14-2005, 05:14 PM   #13
Old Git
 
plattyaj's Avatar
 
Join Date: Feb 2005
Location: Arlington, VA
Posts: 113
Default

Quote:
Originally Posted by fov
Thanks for posting the response! That is such a weird solution. I wonder what changing the name of the .exe has to do with anything.

I'll stick this info in my box of Sierra tricks for the next time something like this comes up...

emily
It's not changing the name of the executable, it's using a different executable. The CD came with two versions. The instructions get you to copy the other one off the CD and then change the shortcut to point to that one.

This works for some other Sierra games too - one of the Phantasmagoria games if memory serves me right.

Andy.
__________________
I'm not really here - it's just your warped imagination.
plattyaj is offline  
Old 11-30-2005, 07:32 PM   #14
Junior Member
 
Join Date: Nov 2005
Posts: 2
Default

I tried copying the file and changing the path, I set the compatibility for Windows 95, I set it to run at 640 x 480, in 256 colors, but now it gives the error, "Windows Title Not Found". What is causing this?
poco_87 is offline  
Old 11-30-2005, 07:42 PM   #15
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

Welcome to the forum, Poco. :) Are you trying to run the DOS or Windows version of the game? How are you trying to launch it? (i.e. desktop shortcut, start menu, etc.)

Do you have Service Pack 2 installed?

EDIT: I found this on NT Compatible. Try it and see if it fixes the problem:

Quote:
The basic problem is, the game fails to add shortcuts to the Windows Start Menu under Win2K and later - therefore the previous "Windows Title Not Found Error". That isn't an incompatibility issue, Sierra seems to have used some quite advanced techniques in its' Windows 3.11 games, including some sort of universal game loader - the SIERRAW.EXE file.

SIERRAW.EXE is -not- the game's exe file, and it requires the respective RESOURCE.WIN file passed to it as the command-line parameter - which I found out after a quick googling for some help. That however didn't solve all my problems, so here's a quick guide to what should work anytime - e.g. if it works on my buggy machine, it has to work on yours...

1) Copy all the files into a directory of your choice on the hard drive - a rather crude method, but with today's hard drives and CD-ROM speeds, not much of a problem. I used the directory the installation uses by default - C:\SIERRA\KQ7\ - if there are problems, try and use a directory that's pre-Win95 compatible (directory names under eight characters, no characters that aren't 7-bit ASCII). I'll call this KQ7 Path from now on.

2) Copy KQ7 Path\English into KQ7 Path

3) Edit KQ7 Path\SIERRA.INF, and add the lines:

[Misc]
SourceDir=c:\sierra\kq7

4) Edit KQ7 Path\RESOURCE.WIN, and add the lines:

resAud = KQ7 Path\
resSfx = KQ7 Path\
patchDir = KQ7 Path\
movieDir = KQ7 Path\AVI\
robot = KQ7 Path\AVI\
audio = KQ7 Path\
resMap = KQ7 Path\;KQ7 Path\
fov is offline  
Old 12-03-2005, 10:09 AM   #16
Junior Member
 
Join Date: Nov 2005
Posts: 2
Default

It worked! Thanks so much. I've been wanting to play this game for the longest time!
poco_87 is offline  
Old 02-22-2007, 06:03 PM   #17
Junior Member
 
Join Date: Feb 2007
Location: Kansas
Posts: 2
Default Different Error message

Hello! I just purchased the King's Quest Collection (so happy I finally found them compatible for XP); all of them are working fine, except VII which gives the error message "Cwindows\system32\autoexec.nt the system file is not suitable for running ms-dos and microsoft windows applications" any ideas?

any help would be greatly greatly appreciated!
RockChalk is offline  
Old 02-22-2007, 06:16 PM   #18
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

It's a Service Pack 2 issue. This thread should tell you everything you need to know.
fov is offline  
Old 02-22-2007, 06:34 PM   #19
Junior Member
 
Join Date: Feb 2007
Location: Kansas
Posts: 2
Default Thanks!

Man your quick! I just came back to recant my question since I found the error in another forum (probably the same link you put) and copying the autoexec.nt file fixed it. Thanks again for your help and your prompt response!
RockChalk is offline  
Old 02-22-2007, 08:11 PM   #20
fov
Rattenmonster
 
fov's Avatar
 
Join Date: Sep 2003
Location: San Francisco
Posts: 10,404
Default

I just happened to be in the right place at the right time. Glad you figured it out.
fov is offline  
 



Thread Tools

 


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.