Discworld Noir - Vista problems - Page 2 - Adventure Forums
You are viewing an archived version of the site which is no longer maintained.
Go to the current live site or the Adventure Gamers forums
Adventure Gamers



 
 
LinkBack Thread Tools
Old 01-19-2012, 11:58 PM   #21
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Vista64 and the 3-cd version.

I already got it to work with VirtualPC so it's really no big deal.


Edit: come to think of it, one of the last things I had tried last week was applying a no-cd patch. Maybe I should try again with a clean install?
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 01-20-2012, 12:42 AM   #22
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

Give it a try. Even if you are happy with it in VPC, I would still like to see if we can get the patch to work for you. Also, try doing a full install. I tested it on my PC and it is working for me, but that is only one machine with one configuration.
Collector is offline  
Old 01-20-2012, 01:40 AM   #23
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Quote:
Originally Posted by Collector View Post
Give it a try. Even if you are happy with it in VPC, I would still like to see if we can get the patch to work for you. Also, try doing a full install. I tested it on my PC and it is working for me, but that is only one machine with one configuration.
I'll try this tomorrow and keep you updated.

About the full install though, I ALWAYS do a full install because disk space has always been the least of my worries...
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 01-22-2012, 06:05 AM   #24
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Same thing again: full install + your patch = blank window + crash.

Every single thing I've tried so far has resulted in a blank window and a crash...

Cursed Vista64...
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 01-22-2012, 07:33 AM   #25
Member
 
Join Date: Apr 2011
Location: RODOS-GREECE
Posts: 69
Default

How about the Microsoft application compatibility toolkit?

http://www.microsoft.com/download/en...s.aspx?id=7352

Maybe the game is listed in there (aka supported).

Other than that the best solution to play the game is in it's native enviroment under a Virtual Machine (VPC, Virtualbox, VMWare Player). And without a glitch too.
tsampikos is offline  
Old 01-22-2012, 10:49 AM   #26
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

He already has the game running in VPC. He was just helping me by testing my patch to see it it could be made to run natively on his Vista.

@TimovieMan, This is something other than the usual Vista/Win7 compatibility problems. Using my launcher to start the game, does the screen go black for a second or two before the game window is created? I suspect that it may have to do with your graphics driver. What graphics adapter do you have and have tried to update the driver?
Collector is offline  
Old 01-23-2012, 12:32 PM   #27
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Quote:
Originally Posted by Collector View Post
@TimovieMan, This is something other than the usual Vista/Win7 compatibility problems. Using my launcher to start the game, does the screen go black for a second or two before the game window is created? I suspect that it may have to do with your graphics driver. What graphics adapter do you have and have tried to update the driver?
When using your launcher, the screen does go black for a fraction of a second before it creates the game window (something to do with that ResChange.exe, I guess?).
The game window itself is blank, or rather "see-through". It creates the outline of the window, but the rest is just my wallpaper and desktop shortcuts that were underneath it.
After about 10 seconds I get an error message that the tin3_dxd.exe no longer works.

My computer system is:
Intel Core2 Quad CPU Q9400 @ 2.66GHz (4 CPUs)
8 GB RAM
Graphics card: NVIDIA GeForce GTX 260
4 GB total video RAM
Operating system: Vista 64-bit Ultimate Edition

Graphics drivers are up-to-date. Most recent drivers for my card were released in October, my last driver update was in November (when I started playing L.A. Noire).

Do you require further info?
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 01-24-2012, 12:04 AM   #28
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

Yes the screen going black is the color depth dropping to 16-bit. No need to mention that your hardware is more that able to handle the demands of such an old game. Did you get the WDM driver from Microsoft or did you download the driver from NVIDIA? Some compatibility issues can be resolved by downgrading the driver to an earlier version, but I am not necessarily suggesting that you do it. One thing to try is to update your DirectX 9c.

http://www.microsoft.com/download/en...s.aspx?id=8109
Collector is offline  
Old 01-25-2012, 08:07 AM   #29
She Wants Revenge
 
millenia's Avatar
 
Join Date: Dec 2005
Location: Finland
Posts: 494
Default

The patch seems to work fine at least when just trying it out (through the opening scenes), thanks a bunch.
__________________
Currently playing: AlternativA, Diablo III
Recently finished: Hector - Episode 1, Dear Esther, Gemini Rue, Sherlock Holmes vs. Jack the Ripper, Blackwell trilogy
All-time favourites: Discworld Noir, Gabriel Knight trilogy
millenia is offline  
Old 01-25-2012, 11:25 AM   #30
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Quote:
Originally Posted by Collector View Post
Did you get the WDM driver from Microsoft or did you download the driver from NVIDIA? Some compatibility issues can be resolved by downgrading the driver to an earlier version, but I am not necessarily suggesting that you do it. One thing to try is to update your DirectX 9c.
I downloaded my drivers from NVIDIA, not Microsoft.

The DirectX update didn't work either, same result: blank window and a crash.

I don't plan on downgrading my drivers to test this, though. Don't want to potentially open up a can of worms with my L.A. Noire playthrough...
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 01-25-2012, 02:09 PM   #31
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

Understood. As I said, it does seem to be some other issue than what others have had with the game on Vista/Win7, so it is more likely that it is something unique with your particular hardware and or configuration. Not really worth the effort track down for one game, especially since you have that game successfully running in VPC. I consider the use of a VM a course of last resort, but sometimes it is the easiest route. Anyway, thanks for testing my patch.
Collector is offline  
Old 01-26-2012, 04:01 AM   #32
Filmfreak
 
TimovieMan's Avatar
 
Join Date: Oct 2011
Location: Belgium
Posts: 1,049
Default

Quote:
Originally Posted by Collector View Post
I consider the use of a VM a course of last resort, but sometimes it is the easiest route.
I did consider it a last resort too, until I had one set up a few months ago. Since then I've decided that it really isn't that much more of a hassle than trying to find multiple patches or making registry adjustments.
Quote:
Anyway, thanks for testing my patch.
Thank YOU for making this patch. Even though it didn't help me, there are already a couple of other people that were helped by it, and I'm sure more will follow...
__________________
Currently playing: Again, Escape from Monkey Island (replay), King's Quest VI: Heir Today, Gone Tomorrow
Next in line: King's Quest VII: The Princeless Bride, Gabriel Knight: Sins of the Fathers, The Last Express, Time Hollow
Recently finished: King's Quest V: Absence Makes the Heart Go Yonder, The Curse of Monkey Island (replay), The Elder Scrolls IV: Oblivion (abandoned), Mass Effect 3
TimovieMan is offline  
Old 03-26-2012, 09:53 AM   #33
Junior Member
 
Join Date: Mar 2012
Posts: 1
Default

Quote:
Originally Posted by TimovieMan View Post
I did consider it a last resort too, until I had one set up a few months ago. Since then I've decided that it really isn't that much more of a hassle than trying to find multiple patches or making registry adjustments.
Thank YOU for making this patch. Even though it didn't help me, there are already a couple of other people that were helped by it, and I'm sure more will follow...
Hi guys.
To Collector-i have installed a DN and also your patch.Everything is working nice,no breakdowns after intro, but when I want to load a saved game game crushes.Then I get this notification "Assert Message: Can t find CHUNK_CDPLAY_FILENUM.
And btw. I don t load from the main menu.When is the first scene where you can control Lewton in office,then I press F1-load and then all that happens..

Last edited by ivan70; 03-26-2012 at 10:16 AM.
ivan70 is offline  
Old 03-26-2012, 09:19 PM   #34
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

Try pressing F1 to bring up the save/load game dialog.
Collector is offline  
Old 04-05-2012, 09:51 AM   #35
Senior Member
 
Marduk's Avatar
 
Join Date: Jul 2009
Location: You want to know where I live? Are you some kind of stalker?
Posts: 279
Send a message via MSN to Marduk Send a message via Yahoo to Marduk
Default

Quote:
Originally Posted by Jeppe View Post
Here is the trick:

Using REGEDT32, locate the Discworld Noir registry key at "HKEY_LOCAL_MACHINE\SOFTWARE\Perfect Entertainment\Discworld Noir". Under it there should be a value called "Start Windowed", which is set to "No" by default. Change it to "Yes".
I can't find this directory in regedt32 OR regedit :frown;

EDIT: NM, I was able to download the correct reg from one of the above links
__________________
I'm not nearly as miserable as I appear to be. And I don't mean to argumentative but that's how my conversations tend to seem.

Last edited by Marduk; 04-05-2012 at 10:00 AM.
Marduk is offline  
Old 04-05-2012, 12:06 PM   #36
Senior Member
 
Collector's Avatar
 
Join Date: Jun 2007
Posts: 775
Default

Quote:
Originally Posted by Marduk View Post
I can't find this directory in regedt32 OR regedit :frown;

EDIT: NM, I was able to download the correct reg from one of the above links
The Patch that I posted addresses this.
Collector is offline  
 



Thread Tools

 


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.