Gabriel Knight 3 issues - Adventure Forums
You are viewing an archived version of the site which is no longer maintained.
Go to the current live site or the Adventure Gamers forums
Adventure Gamers



 
 
LinkBack Thread Tools
Old 03-20-2007, 08:01 AM   #1
Junior Member
 
Guitaraholic's Avatar
 
Join Date: Feb 2007
Location: Florida
Posts: 7
Send a message via Yahoo to Guitaraholic
Default Gabriel Knight 3 issues

All right, so I'm not sure if this is the right place to post this but I have faith in the admins to move it if I'm wrong

I have Gabriel Knight 3 on an XP computer and it freezes at the beginning. I hear the Sierra intro (don't see it though) and after that, NOT RESPONDING. Any suggestions? I've tried changing compatibility and that makes things worse. Thought I'd see if someone else knew what was goin' on.

Thanks!!!!
Guitaraholic is offline  
Old 03-27-2007, 06:38 AM   #2
Junior Member
 
Join Date: Mar 2007
Posts: 3
Default

same problem here...using windows XP SP2. Video card is Sparkle GeForce Fx 5200.

I also tried to update my video drivers, wmedia player and directx but still can't see the sierra intro, I can hear it but could not see it then it freezes.

Any help out there?
sshhaaddooww is offline  
Old 03-27-2007, 07:36 AM   #3
Senior Member
 
Join Date: Jan 2004
Location: Denmark
Posts: 168
Default

It's a codec problem. The logo videos are compressed with a codec which your computer doesn't have, or rather that the codec version on your computer isn't compatible with the one used by GK3s player code. Exact same thing happened for me. Forunately this seems to only affect the logo video, not any later cutscenes.

The easy fix is taking another avi file (any that can be played on your computer), moving it to the folder where GK3 keeps the videos and rename it to sierra.avi, logo.avi or whatever it's called. I'm sorry I can't be more precise, I don't have GK3 installed at the moment.
Another solution is to repack the video with a video editing program. It's hardly worth the effort, but it's what I ended up doing when making an easy-install version of the game for my girlfriend.
GarageGothic is offline  
Old 03-27-2007, 08:12 AM   #4
Junior Member
 
Guitaraholic's Avatar
 
Join Date: Feb 2007
Location: Florida
Posts: 7
Send a message via Yahoo to Guitaraholic
Default

But does that keep the game from freezing after that logo/intro movie plays? What you said makes sense, just can't test it right now and wonder if that fixes the freezing issue as well.

Thanks for your help!!!

A
Guitaraholic is offline  
Old 03-27-2007, 08:34 AM   #5
Senior Member
 
Join Date: Jan 2004
Location: Denmark
Posts: 168
Default

Well, my problem was that I got a black screen with audio during the logo, and then nothing more happened. This solved it, so I hope it will do the same for you.
GarageGothic is offline  
Old 03-28-2007, 03:14 AM   #6
Junior Member
 
Join Date: Mar 2007
Posts: 3
Default

I tried what you said but still no luck, I also changed the sierra.avi file to a short movie clip and renaming it, I can hear the movie clip but could not see it. By the way I can play the sierra.avi through my media player I think my codecs are supported the problem is why doesn't it show up when I run GK3
sshhaaddooww is offline  
Old 03-28-2007, 02:38 PM   #7
Junior Member
 
Guitaraholic's Avatar
 
Join Date: Feb 2007
Location: Florida
Posts: 7
Send a message via Yahoo to Guitaraholic
Default

well i tried with success. All I did was grab a REALLY short avi file on my computer, renamed it sierra.avi and copied it over the one in the Data directory and it worked. As a note I moved ALL the.BRN files from the cd's to that Data directory as well (day1.brn, day2.brn, etc.), I read somewhere else that that fixes my issue as well but maybe it was the combination. Hope maybe that helps shadow.
Guitaraholic is offline  
Old 03-28-2007, 04:11 PM   #8
DAVE
 
Catbert's Avatar
 
Join Date: Oct 2004
Location: Portugal
Posts: 1,326
Default

Someone said it was a codec issue, not sure if it is, but if so, http://www.headbands.com/gspot/ <- use this on the original file, find out if it uses codecs you don't have and get them.
__________________
IS THAT DAVE?
Catbert is offline  
Old 03-30-2007, 04:23 AM   #9
Junior Member
 
Join Date: Mar 2007
Posts: 3
Default

finally made it work....woooppppeeeee!

just found out that not all avi files work, I managed to get it to work by an avi file encoded by CRAM CODEC, I also converted the original siera.avi to get the original effect!
sshhaaddooww is offline  
Old 06-19-2007, 08:35 AM   #10
The Quiet One
 
DustyShinigami's Avatar
 
Join Date: Oct 2006
Location: Staffordshire, UK
Posts: 1,986
Default

Didn't see the point starting a new thread, so...

Does anyone here experience any performance issues with this game, especially with the camera? Whenever moving the camera around the game environment it seems to run quite jittery and slow. I assumed it might be an XP thing so I tried it on my dad's 98 rig and i still get the same problem. My computer's spec (and my dad's) is more than enough for this game so i can't understand why there are slow downs.

Are there any patches or updates for this game that might iron out a few wrinkles, or am i gonna have to just swallow it?

Thanks
__________________
Now Playing: Broken Sword: Shadow of the Templars - The Director's Cut (DS and iPhone), DOOM 3: Resurrection of Evil, Hotel Dusk: Room 215, Phoenix Wright: Ace Attorney Justice for All, Silent Hill - HD Collection
Recently Completed: Max Payne, Max Payne 2: The Fall of Max Payne
Next: Bayonetta, Devil May Cry - HD Collection, Max Payne 3, Metal Gear Solid - HD Collection, Silent Hill: Downpour
DustyShinigami is offline  
Old 06-20-2007, 06:16 AM   #11
The Quiet One
 
DustyShinigami's Avatar
 
Join Date: Oct 2006
Location: Staffordshire, UK
Posts: 1,986
Default

Anyone?
__________________
Now Playing: Broken Sword: Shadow of the Templars - The Director's Cut (DS and iPhone), DOOM 3: Resurrection of Evil, Hotel Dusk: Room 215, Phoenix Wright: Ace Attorney Justice for All, Silent Hill - HD Collection
Recently Completed: Max Payne, Max Payne 2: The Fall of Max Payne
Next: Bayonetta, Devil May Cry - HD Collection, Max Payne 3, Metal Gear Solid - HD Collection, Silent Hill: Downpour
DustyShinigami is offline  
Old 08-14-2007, 09:53 PM   #12
Junior Member
 
Join Date: Aug 2007
Posts: 1
Default

I still didn't solve the black screen problem =/
wingnux is offline  
Old 06-16-2008, 02:23 AM   #13
Junior Member
 
Join Date: Jun 2008
Posts: 1
Default

Hi. I know how to solve your problem. I was looking for some advice since almost a year, and today (on this forum) I found it.

Here it is, step by step:

1. I searched for some .avi file, encoded in CRAM codec, like somebody wrote here already. I founded and downloaded this file (it could be any other .avi file encoded by CRAM codec, but maybe not everybody know how to find one): http://samples.mplayerhq.hu/V-codecs...ock-cram16.avi

This is ca 3 second .avi film.

2. I placed this .avi file in my Gabiel Knight 3 Data folder:
C:/Games/Sierra/Gabriel Knight 3/Data/

3. Then I renamed the original Sierra (.avi) file to Sierraold, and I also renamed downloaded clock-cram16 to Sierra. Remember that ".avi" must stay ".avi", do not change it! You change only file name. :-)

Now we have new Sierra.avi file, encoded in CRAM codec.

4. I made *nothing* more. That's all. Game is working already, without any other steps.

I hope I helped you. Sorry for my pure english.
Cheers! :-)
squirel is offline  
Old 06-17-2008, 01:23 PM   #14
Junior Member
 
Join Date: Jun 2008
Posts: 2
Default still not working

Hi all,

I have the same issue. Black screen and a not responding message from Windows upon starting up this game.

I tried replacing the Sierra avi with the suggested file, but the result is still the same.

Black screen and not responding....

Should I download some drivers or codecs perhaps?
Or is there any other way to get this game starting?

Thanks,
Ivar
Ivar is offline  
Old 07-02-2008, 02:57 AM   #15
Junior Member
 
Join Date: Jul 2008
Posts: 1
Default This Really Works!!!

I tried it on vista 32 and it really does the job.

enjoy GK3


Quote:
Originally Posted by squirel View Post
Hi. I know how to solve your problem. I was looking for some advice since almost a year, and today (on this forum) I found it.

Here it is, step by step:

1. I searched for some .avi file, encoded in CRAM codec, like somebody wrote here already. I founded and downloaded this file (it could be any other .avi file encoded by CRAM codec, but maybe not everybody know how to find one): http://samples.mplayerhq.hu/V-codecs...ock-cram16.avi

This is ca 3 second .avi film.

2. I placed this .avi file in my Gabiel Knight 3 Data folder:
C:/Games/Sierra/Gabriel Knight 3/Data/

3. Then I renamed the original Sierra (.avi) file to Sierraold, and I also renamed downloaded clock-cram16 to Sierra. Remember that ".avi" must stay ".avi", do not change it! You change only file name. :-)

Now we have new Sierra.avi file, encoded in CRAM codec.

4. I made *nothing* more. That's all. Game is working already, without any other steps.

I hope I helped you. Sorry for my pure english.
Cheers! :-)
ori218 is offline  
Old 07-24-2008, 05:57 AM   #16
Junior Member
 
Join Date: Jun 2008
Posts: 2
Default

For those of you who still cannot start-up the game, the following helpt for me:

Uninstalling K-Lite codec packages!

It apparantly installed codecs that conflict with the ones used in GK3.
You can use VLC-player to run movies anyway, so such a codec package is not needed.

I don't know if the same problem can occurr with other codec packages, but its worth a try ;-)

Ivar
Ivar is offline  
Old 08-12-2008, 10:48 AM   #17
Junior Member
 
Join Date: Aug 2008
Posts: 2
Default

Hi, new member here!

I had the same problem running it on Windows Vista, but followed squirel's advice, and things seemed to work fine.

However, I am now experiencing more or less the same problem halfway through the game. Here's a post I made in another forum:

"Not sure where else I can turn to with my problem...

I believe I have about 480 points and I'm using SIDNEY with Grace, trying to analyase things. But, whenever I try using "view geometry" on either of the two parchments that were found in Lady Howard and Estelle's room, I get a few bleep blop sounds and it looks as if the in-game computer is loading, but then nothing happens. Can't even right click to restore my last game, and the Escape button does nothing.

The same thing also happens when I try analysing the unknown fingerprint that you get off the envelope containing the Serpent Rouge document. It appears to be loading for a bit, but nothing happens, and I have to use Alt Ctr Del in order to close the game down.

Does anyone know what's wrong? How can I overcome this problem?"

I believe I've figured out what the problem is, having snooped around in the folders of the second CD of the game; in the data folder there are a few AVI files, and I'm guessing the game is trying to play them, but due to the codec problem mentioned above they can't get played. So I only get the bleep bloop sounds of the geometry map tracing thingy, but I don't get the video, and the result is that the game crashes.

As these are contained on the actual CD, I can't replace them with other video files.

So, what do I do now? Anywhere I could get this needed codec from? What's it called?
Evil Eivind is offline  
Old 08-12-2008, 11:00 AM   #18
Senior Member
 
Kurufinwe's Avatar
 
Join Date: Aug 2005
Location: Santa Barbara, CA
Posts: 3,038
Default

I had the exact same problem and worked around it by replacing the videos, though I can't remember exactly how I did it. Have you tried just putting the replacements in the installation folder? Maybe if they have the right file names the game will just open those rather than go look on the CD.
__________________
Currently reading: Dune (F. Herbert)
Recently finished: Harry Potter and the Prisoner of Azkaban (J. K. Rowling) [++], La Nuit des Temps (R. Barjavel) [+++]
Currently playing: Skyrim
Recently finished: MCF: Escape from Ravenhearst [+], The Walking Dead, ep. 1 [+++], Gray Matter [++]
Kurufinwe is offline  
Old 08-12-2008, 12:45 PM   #19
Junior Member
 
Join Date: Aug 2008
Posts: 2
Default

Wow, that actually worked. Didn't expect it to. Thanks a bunch!
Evil Eivind is offline  
Old 09-13-2008, 07:10 AM   #20
Junior Member
 
Join Date: Sep 2008
Posts: 4
Default

Quote:
Originally Posted by Kurufinwe View Post
I had the exact same problem and worked around it by replacing the videos, though I can't remember exactly how I did it. Have you tried just putting the replacements in the installation folder? Maybe if they have the right file names the game will just open those rather than go look on the CD.
Hi, I have a similar problem. On Day 2, using Sydney, when I click View Geometry, the game just locks up and stops responding. I don't hear the sounds, or see any video. I uninstalled the K-Lite codec pack, and still no luck. I tried to figure out what you meant by "putting the replacements in the installation folder.." so I just copied all the videos on disc two into the data folder from my installation.
It still won't work. Someone please help me?? I'm using XP SP3 and I can't figure out how to fix this
ErikaAeternam is offline  
 



Thread Tools

 


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.